FreeBSD : krfb -- Multiple security issues in bundled libvncserver (fb25333d-442f-11e4-98f3-5453ed2e2b49)

Medium Nessus Plugin ID 77837


The remote FreeBSD host is missing a security-related update.


Martin Sandsmark reports :

krfb 4.14 [and earlier] embeds libvncserver which has had several security issues.

Several remotely exploitable security issues have been uncovered in libvncserver, some of which might allow a remote authenticated user code execution or application crashes.


Update the affected package.

See Also

Plugin Details

Severity: Medium

ID: 77837

File Name: freebsd_pkg_fb25333d442f11e498f35453ed2e2b49.nasl

Version: $Revision: 1.2 $

Type: local

Published: 2014/09/25

Modified: 2014/10/02

Dependencies: 12634

Risk Information

Risk Factor: Medium


Base Score: 6.5

Vector: CVSS2#AV:N/AC:L/Au:S/C:P/I:P/A:P

Vulnerability Information

CPE: p-cpe:/a:freebsd:freebsd:krfb, cpe:/o:freebsd:freebsd

Required KB Items: Host/local_checks_enabled, Host/FreeBSD/release, Host/FreeBSD/pkg_info

Patch Publication Date: 2014/09/25

Vulnerability Publication Date: 2014/09/23

Reference Information

CVE: CVE-2014-6055