openSUSE Security Update : ppp (openSUSE-SU-2014:1135-1)

High Nessus Plugin ID 77719


The remote openSUSE host is missing a security update.


ppp was updated to fix an integer overflow in option parsing.
(CVE-2014-3158, bnc#891489).


Update the affected ppp packages.

See Also

Plugin Details

Severity: High

ID: 77719

File Name: openSUSE-2014-545.nasl

Version: $Revision: 1.2 $

Type: local

Agent: unix

Published: 2014/09/17

Modified: 2014/11/18

Dependencies: 12634

Risk Information

Risk Factor: High


Base Score: 7.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Vulnerability Information

CPE: p-cpe:/a:novell:opensuse:ppp, p-cpe:/a:novell:opensuse:ppp-debuginfo, p-cpe:/a:novell:opensuse:ppp-debugsource, p-cpe:/a:novell:opensuse:ppp-devel, cpe:/o:novell:opensuse:12.3, cpe:/o:novell:opensuse:13.1

Required KB Items: Host/local_checks_enabled, Host/SuSE/release, Host/SuSE/rpm-list, Host/cpu

Patch Publication Date: 2014/09/09

Reference Information

CVE: CVE-2014-3158