SuSE 11.3 Security Update : ppp (SAT Patch Number 9648)

High Nessus Plugin ID 77524


The remote SuSE 11 host is missing a security update.


This ppp update fixes a potential security issue that an unprivileged attacker could access privileged options :

- integer overflow in option parsing (CVE-2014-3158, bnc#891489)


Apply SAT patch number 9648.

See Also

Plugin Details

Severity: High

ID: 77524

File Name: suse_11_ppp-140826.nasl

Version: $Revision: 1.2 $

Type: local

Agent: unix

Published: 2014/09/04

Modified: 2014/11/18

Dependencies: 12634

Risk Information

Risk Factor: High


Base Score: 7.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Vulnerability Information

CPE: p-cpe:/a:novell:suse_linux:11:ppp, cpe:/o:novell:suse_linux:11

Required KB Items: Host/local_checks_enabled, Host/cpu, Host/SuSE/release, Host/SuSE/rpm-list

Patch Publication Date: 2014/08/26

Reference Information

CVE: CVE-2014-3158