openSUSE Security Update : gpgme (openSUSE-SU-2014:1039-1)

Medium Nessus Plugin ID 77289


The remote openSUSE host is missing a security update.


This gpgme update to version 1.4.4 fixes the following security and non i security issues :

- Fixed possible overflow in gpgsm and uiserver engines.
(CVE-2014-3564, bnc#890123)

- Fixed possibled segv in gpgme_op_card_edit.

- Fixed minor memleaks and possible zombie processes.

- Fixed prototype inconsistencies and void pointer arithmetic.


Update the affected gpgme packages.

See Also

Plugin Details

Severity: Medium

ID: 77289

File Name: openSUSE-2014-500.nasl

Version: $Revision: 1.2 $

Type: local

Agent: unix

Published: 2014/08/21

Modified: 2014/10/23

Dependencies: 12634

Risk Information

Risk Factor: Medium


Base Score: 6.8

Vector: CVSS2#AV:N/AC:M/Au:N/C:P/I:P/A:P

Vulnerability Information

CPE: p-cpe:/a:novell:opensuse:gpgme, p-cpe:/a:novell:opensuse:gpgme-debugsource, p-cpe:/a:novell:opensuse:libgpgme-devel, p-cpe:/a:novell:opensuse:libgpgme11, p-cpe:/a:novell:opensuse:libgpgme11-32bit, p-cpe:/a:novell:opensuse:libgpgme11-debuginfo, p-cpe:/a:novell:opensuse:libgpgme11-debuginfo-32bit, cpe:/o:novell:opensuse:12.3, cpe:/o:novell:opensuse:13.1

Required KB Items: Host/local_checks_enabled, Host/SuSE/release, Host/SuSE/rpm-list, Host/cpu

Patch Publication Date: 2014/08/11

Reference Information

CVE: CVE-2014-3564