FreeBSD : nginx -- inject commands into SSL session vulnerability (ad747a01-1fee-11e4-8ff1-f0def16c5c1b)

Medium Nessus Plugin ID 77109


The remote FreeBSD host is missing one or more security-related updates.


The nginx project reports :

Security: pipelined commands were not discarded after STARTTLS command in SMTP proxy (CVE-2014-3556); the bug had appeared in 1.5.6.


Update the affected packages.

See Also

Plugin Details

Severity: Medium

ID: 77109

File Name: freebsd_pkg_ad747a011fee11e48ff1f0def16c5c1b.nasl

Version: $Revision: 1.2 $

Type: local

Published: 2014/08/10

Modified: 2015/01/02

Dependencies: 12634

Risk Information

Risk Factor: Medium


Base Score: 4.3

Vector: CVSS2#AV:N/AC:M/Au:N/C:P/I:N/A:N

Vulnerability Information

CPE: p-cpe:/a:freebsd:freebsd:nginx, p-cpe:/a:freebsd:freebsd:nginx-devel, cpe:/o:freebsd:freebsd

Required KB Items: Host/local_checks_enabled, Host/FreeBSD/release, Host/FreeBSD/pkg_info

Patch Publication Date: 2014/08/09

Vulnerability Publication Date: 2014/08/05

Reference Information

CVE: CVE-2014-3556