Debian DSA-2998-1 : openssl - security update

High Nessus Plugin ID 77035

Synopsis

The remote Debian host is missing a security-related update.

Description

Multiple vulnerabilities have been identified in OpenSSL, a Secure Sockets Layer toolkit, that may result in denial of service (application crash, large memory consumption), information leak, protocol downgrade. Additionally, a buffer overrun affecting only applications explicitly set up for SRP has been fixed (CVE-2014-3512 ).

Detailed descriptions of the vulnerabilities can be found at:
www.openssl.org/news/secadv/20140806.txt

It's important that you upgrade the libssl1.0.0 package and not just the openssl package.

All applications linked to openssl need to be restarted. You can use the 'checkrestart' tool from the debian-goodies package to detect affected programs. Alternatively, you may reboot your system.

Solution

Upgrade the openssl packages.

For the stable distribution (wheezy), these problems have been fixed in version 1.0.1e-2+deb7u12.

See Also

https://security-tracker.debian.org/tracker/CVE-2014-3512

https://www.openssl.org/news/secadv/20140806.txt

https://packages.debian.org/source/wheezy/openssl

https://www.debian.org/security/2014/dsa-2998

Plugin Details

Severity: High

ID: 77035

File Name: debian_DSA-2998.nasl

Version: 1.16

Type: local

Agent: unix

Published: 2014/08/07

Updated: 2018/11/10

Dependencies: 12634

Risk Information

Risk Factor: High

CVSS v2.0

Base Score: 7.5

Temporal Score: 5.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

Vulnerability Information

CPE: p-cpe:/a:debian:debian_linux:openssl, cpe:/o:debian:debian_linux:7.0

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2014/08/07

Reference Information

CVE: CVE-2014-3505, CVE-2014-3506, CVE-2014-3507, CVE-2014-3508, CVE-2014-3509, CVE-2014-3510, CVE-2014-3511, CVE-2014-3512, CVE-2014-5139

BID: 69075, 69076, 69077, 69078, 69079, 69081, 69082, 69083, 69084

DSA: 2998