CVE-2014-3512

high
New! CVE Severity Now Using CVSS v3

The calculated severity for CVEs has been updated to use CVSS v3 by default. CVEs that do not have a CVSS v3 score will fall back CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Description

Multiple buffer overflows in crypto/srp/srp_lib.c in the SRP implementation in OpenSSL 1.0.1 before 1.0.1i allow remote attackers to cause a denial of service (application crash) or possibly have unspecified other impact via an invalid SRP (1) g, (2) A, or (3) B parameter.

References

ftp://ftp.netbsd.org/pub/NetBSD/security/advisories/NetBSD-SA2014-008.txt.asc

http://aix.software.ibm.com/aix/efixes/security/openssl_advisory10.asc

http://lists.opensuse.org/opensuse-updates/2014-08/msg00036.html

http://marc.info/?l=bugtraq&m=142660345230545&w=2

http://secunia.com/advisories/59700

http://secunia.com/advisories/59710

http://secunia.com/advisories/59756

http://secunia.com/advisories/60022

http://secunia.com/advisories/60221

http://secunia.com/advisories/60493

http://secunia.com/advisories/60803

http://secunia.com/advisories/60810

http://secunia.com/advisories/60917

http://secunia.com/advisories/60921

http://secunia.com/advisories/61017

http://secunia.com/advisories/61100

http://secunia.com/advisories/61171

http://secunia.com/advisories/61184

http://secunia.com/advisories/61775

http://secunia.com/advisories/61959

http://security.gentoo.org/glsa/glsa-201412-39.xml

http://support.f5.com/kb/en-us/solutions/public/15000/500/sol15565.html

http://www.debian.org/security/2014/dsa-2998

http://www.huawei.com/en/security/psirt/security-bulletins/security-advisories/hw-372998.htm

http://www.securityfocus.com/bid/69083

http://www.securitytracker.com/id/1030693

http://www.tenable.com/security/tns-2014-06

http://www-01.ibm.com/support/docview.wss?uid=nas8N1020240

http://www-01.ibm.com/support/docview.wss?uid=swg21682293

http://www-01.ibm.com/support/docview.wss?uid=swg21683389

http://www-01.ibm.com/support/docview.wss?uid=swg21686997

https://exchange.xforce.ibmcloud.com/vulnerabilities/95158

https://git.openssl.org/gitweb/?p=openssl.git;a=commit;h=4a23b12a031860253b58d503f296377ca076427b

https://lists.balabit.hu/pipermail/syslog-ng-announce/2014-September/000196.html

https://www.freebsd.org/security/advisories/FreeBSD-SA-14:18.openssl.asc

https://www.openssl.org/news/secadv_20140806.txt

Details

Source: MITRE

Published: 2014-08-13

Updated: 2017-08-29

Type: CWE-119

Risk Information

CVSS v2

Base Score: 7.5

Vector: AV:N/AC:L/Au:N/C:P/I:P/A:P

Impact Score: 6.4

Exploitability Score: 10

Severity: HIGH

Tenable Plugins

View all (18 total)

IDNameProductFamilySeverity
108516pfSense < 2.1.5 Multiple Vulnerabilities ( SA-14_14 )NessusCGI abuses
high
81651Apache Tomcat 8.0.x < 8.0.15 Multiple Vulnerabilities (POODLE)NessusWeb Servers
high
81650Apache Tomcat 7.0.x < 7.0.57 Multiple Vulnerabilities (POODLE)NessusWeb Servers
high
81649Apache Tomcat 6.0.x < 6.0.43 Multiple Vulnerabilities (POODLE)NessusWeb Servers
high
80722Oracle Solaris Third-Party Patch Update : openssl (cve_2014_3505_denial_of)NessusSolaris Local Security Checks
high
80244GLSA-201412-39 : OpenSSL: Multiple vulnerabilitiesNessusGentoo Local Security Checks
high
78420Juniper Junos Multiple OpenSSL Vulnerabilities (JSA10649)NessusJunos Local Security Checks
high
78334Amazon Linux AMI : openssl (ALAS-2014-391)NessusAmazon Linux Local Security Checks
high
78078WinSCP 5.x < 5.5.5 Multiple VulnerabilitiesNessusWindows
high
77603AIX OpenSSL Advisory : openssl_advisory10.ascNessusAIX Local Security Checks
high
77317openSUSE Security Update : openssl (openSUSE-SU-2014:1052-1)NessusSuSE Local Security Checks
high
8354OpenSSL < 0.9.8zb / < 1.0.0n / < 1.0.1i Multiple VulnerabilitiesNessus Network MonitorWeb Servers
medium
77182stunnel < 5.03 OpenSSL Multiple VulnerabilitiesNessusWindows
high
77091Slackware 13.0 / 13.1 / 13.37 / 14.0 / 14.1 / current : openssl (SSA:2014-220-01)NessusSlackware Local Security Checks
high
77088OpenSSL 1.0.1 < 1.0.1i Multiple VulnerabilitiesNessusWeb Servers
high
77085Ubuntu 10.04 LTS / 12.04 LTS / 14.04 LTS : openssl vulnerabilities (USN-2308-1)NessusUbuntu Local Security Checks
high
77036FreeBSD : OpenSSL -- multiple vulnerabilities (8aff07eb-1dbd-11e4-b6ba-3c970e169bc2)NessusFreeBSD Local Security Checks
high
77035Debian DSA-2998-1 : openssl - security updateNessusDebian Local Security Checks
high