Knot DNS < 1.4.5 TSIG Signature Spoofing

medium Nessus Plugin ID 76799
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Synopsis

The remote DNS server is potentially affected by a spoofing attack.

Description

The remote host is running a version of Knot DNS prior to 1.4.5. It is, therefore, affected by an unspecified vulnerability in the TSIG validation code that may allow spoofing attacks due to improper TSIG signature verification.

Solution

Update to version 1.4.5 or later.

See Also

http://freecode.com/projects/knot-dns/releases/363022

Plugin Details

Severity: Medium

ID: 76799

File Name: knot_dns_1_4_5.nasl

Version: 1.5

Type: remote

Family: DNS

Published: 7/25/2014

Updated: 11/28/2018

Dependencies: knot_dns_version.nasl

Configuration: Enable paranoid mode

Risk Information

CVSS v2

Risk Factor: Medium

Base Score: 5

Temporal Score: 3.7

Vector: AV:N/AC:L/Au:N/C:N/I:P/A:N

Temporal Vector: E:U/RL:OF/RC:C

Vulnerability Information

CPE: x-cpe:/a:cz.nic:knot_dns

Required KB Items: knot_dns/proto, Settings/ParanoidReport

Exploit Ease: No known exploits are available

Patch Publication Date: 4/15/2014

Vulnerability Publication Date: 4/14/2014

Reference Information

BID: 67187