Debian DSA-2985-1 : mysql-5.5 - security update

Medium Nessus Plugin ID 76690

Synopsis

The remote Debian host is missing a security-related update.

Description

Several issues have been discovered in the MySQL database server. The vulnerabilities are addressed by upgrading MySQL to the new upstream version 5.5.38. Please see the MySQL 5.5 Release Notes and Oracle's Critical Patch Update advisory for further details :

- http://dev.mysql.com/doc/relnotes/mysql/5.5/en/news-5-5- 38.html
- http://www.oracle.com/technetwork/topics/security/cpujul 2014-1972956.html

Solution

Upgrade the mysql-5.5 packages.

For the stable distribution (wheezy), these problems have been fixed in version 5.5.38-0+wheezy1.

See Also

https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=754941

https://dev.mysql.com/doc/relnotes/mysql/5.5/en/news-5-5-38.html

http://www.nessus.org/u?77697fb1

https://packages.debian.org/source/wheezy/mysql-5.5

https://www.debian.org/security/2014/dsa-2985

Plugin Details

Severity: Medium

ID: 76690

File Name: debian_DSA-2985.nasl

Version: 1.9

Type: local

Agent: unix

Published: 2014/07/23

Updated: 2018/11/19

Dependencies: 12634

Risk Information

Risk Factor: Medium

CVSS v2.0

Base Score: 6.5

Temporal Score: 4.8

Vector: CVSS2#AV:N/AC:L/Au:S/C:P/I:P/A:P

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

Vulnerability Information

CPE: p-cpe:/a:debian:debian_linux:mysql-5.5, cpe:/o:debian:debian_linux:7.0

Required KB Items: Host/local_checks_enabled, Host/Debian/release, Host/Debian/dpkg-l

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2014/07/22

Reference Information

CVE: CVE-2014-2494, CVE-2014-4207, CVE-2014-4258, CVE-2014-4260

BID: 68564, 68573, 68579, 68593

DSA: 2985