Flash Player <= 14.0.0.125 Multiple Vulnerabilities (APSB14-17)

High Nessus Plugin ID 76413

Synopsis

The remote Windows host has a browser plugin that is affected by multiple vulnerabilities.

Description

According to its version, the instance of Flash Player installed on the remote Windows host is equal or prior to 14.0.0.125. It is, therefore, affected by the following vulnerabilities :

- A CSRF bypassing Same Origin Policy vulnerability exists that could leak potentially sensitive data.
(CVE-2014-4671)

- Multiple unspecified errors exist that could allow unspecified security bypass attacks. (CVE-2014-0537, CVE-2014-0539)

Solution

Upgrade to Adobe Flash Player version 14.0.0.145 or later.

Alternatively, Adobe has made version 13.0.0.231 available for those installations that cannot be upgraded to 14.x.

See Also

https://helpx.adobe.com/security/products/flash-player/apsb14-17.html

http://www.nessus.org/u?0cb17c10

Plugin Details

Severity: High

ID: 76413

File Name: flash_player_apsb14-17.nasl

Version: 1.12

Type: local

Agent: windows

Family: Windows

Published: 2014/07/08

Updated: 2018/07/11

Dependencies: 28211

Risk Information

Risk Factor: High

CVSS v2.0

Base Score: 9.3

Temporal Score: 8.1

Vector: CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:H/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:adobe:flash_player

Required KB Items: SMB/Flash_Player/installed

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2014/07/08

Vulnerability Publication Date: 2014/07/08

Reference Information

CVE: CVE-2014-0537, CVE-2014-0539, CVE-2014-4671

BID: 68454, 68455, 68457