openSUSE Security Update : memcached (openSUSE-SU-2014:0867-1)

Medium Nessus Plugin ID 76365


The remote openSUSE host is missing a security update.


memcached was updated to version 1.4.20 to fix five security issues.

These security issues were fixed :

- DoS when printing out keys to be deleted in verbose mode (CVE-2013-0179)

- Remote DoS (crash) via a request that triggers 'unbounded key print' (CVE-2013-7291)

- Remote DoS (segmentation fault) via a request to delete a key (CVE-2013-7290)

- SASL authentication allows wrong credentials to access memcache (CVE-2013-7239)

- Remote DoS (CVE-2011-4971)


Update the affected memcached packages.

See Also

Plugin Details

Severity: Medium

ID: 76365

File Name: openSUSE-2014-454.nasl

Version: $Revision: 1.2 $

Type: local

Agent: unix

Published: 2014/07/04

Modified: 2015/01/13

Dependencies: 12634

Risk Information

Risk Factor: Medium


Base Score: 5

Vector: CVSS2#AV:N/AC:L/Au:N/C:N/I:N/A:P

Vulnerability Information

CPE: p-cpe:/a:novell:opensuse:memcached, p-cpe:/a:novell:opensuse:memcached-debuginfo, p-cpe:/a:novell:opensuse:memcached-debugsource, cpe:/o:novell:opensuse:12.3, cpe:/o:novell:opensuse:13.1

Required KB Items: Host/local_checks_enabled, Host/SuSE/release, Host/SuSE/rpm-list, Host/cpu

Patch Publication Date: 2014/06/25

Reference Information

CVE: CVE-2011-4971, CVE-2013-0179, CVE-2013-7239, CVE-2013-7290, CVE-2013-7291