openSUSE Security Update : castor (openSUSE-SU-2014:0822-1)

Medium Nessus Plugin ID 76183


The remote openSUSE host is missing a security update.


castor was updated to prevent XXE attacks via crafted XML documents (CVE-2014-3004).


Update the affected castor packages.

See Also

Plugin Details

Severity: Medium

ID: 76183

File Name: openSUSE-2014-435.nasl

Version: $Revision: 1.2 $

Type: local

Agent: unix

Published: 2014/06/23

Modified: 2014/06/24

Dependencies: 12634

Risk Information

Risk Factor: Medium


Base Score: 4.3

Temporal Score: 3.7

Vector: CVSS2#AV:N/AC:M/Au:N/C:P/I:N/A:N

Temporal Vector: CVSS2#E:ND/RL:OF/RC:C

Vulnerability Information

CPE: p-cpe:/a:novell:opensuse:castor, p-cpe:/a:novell:opensuse:castor-demo, p-cpe:/a:novell:opensuse:castor-javadoc, p-cpe:/a:novell:opensuse:castor-test, p-cpe:/a:novell:opensuse:castor-xml, cpe:/o:novell:opensuse:12.3, cpe:/o:novell:opensuse:13.1

Required KB Items: Host/local_checks_enabled, Host/SuSE/release, Host/SuSE/rpm-list

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2014/06/13

Reference Information

CVE: CVE-2013-3004, CVE-2014-3004

BID: 67676