MediaWiki < 1.19.16 / 1.21.10 / 1.22.7 'Special:PasswordReset' XSS

low Nessus Plugin ID 76148
New! Vulnerability Priority Rating (VPR)

Tenable calculates a dynamic VPR for every vulnerability. VPR combines vulnerability information with threat intelligence and machine learning algorithms to predict which vulnerabilities are most likely to be exploited in attacks. Read more about what VPR is and how it is different from CVSS.

VPR Score: 3

Synopsis

The remote web server contains an application that is affected by a cross-site scripting vulnerability.

Description

According to its version number, the instance of MediaWiki running on the remote host is affected by a cross-site scripting vulnerability.
An input-validation flaw exists related to 'Special:PasswordReset'.
This allows a remote attacker to execute arbitrary code within the server and browser trust relationship.

Nessus has not tested for this issue but has instead relied on the application's self-reported version number.

Solution

Upgrade to MediaWiki version 1.19.16 / 1.22.7 or later.

Note that, although version 1.21.10 also addresses the vulnerability, the 1.21.x release branch was obsoleted in June 2014.

See Also

http://www.nessus.org/u?ff8509a9

https://phabricator.wikimedia.org/T67501

https://www.mediawiki.org/wiki/Release_notes/1.19

https://www.mediawiki.org/wiki/Release_notes/1.21

https://www.mediawiki.org/wiki/Release_notes/1.22

Plugin Details

Severity: Low

ID: 76148

File Name: mediawiki_1_21_10.nasl

Version: 1.8

Type: remote

Published: 6/19/2014

Updated: 1/19/2021

Dependencies: mediawiki_detect.nasl

Configuration: Enable paranoid mode

Risk Information

Risk Factor: Low

VPR Score: 3

CVSS Score Source: CVE-2014-3966

CVSS v2.0

Base Score: 2.6

Temporal Score: 2.3

Vector: AV:N/AC:H/Au:N/C:N/I:P/A:N

Temporal Vector: E:H/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:mediawiki:mediawiki

Required KB Items: Settings/ParanoidReport, installed_sw/MediaWiki, www/PHP

Exploit Ease: No exploit is required

Patch Publication Date: 5/29/2014

Vulnerability Publication Date: 5/29/2014

Reference Information

CVE: CVE-2014-3966

BID: 67787

CWE: 20, 74, 79, 442, 629, 711, 712, 722, 725, 750, 751, 800, 801, 809, 811, 864, 900, 928, 931, 990