openSUSE Security Update : miniupnpc (openSUSE-SU-2014:0815-1)

Medium Nessus Plugin ID 76137


The remote openSUSE host is missing a security update.


miniupnpc was updated to 1.9 to fix a potential buffer overrun in miniwget.c (CVE-2014-3985).

Besides that the following issues were fixed :

- added argument remoteHost to UPNP_GetSpecificPortMappingEntry()

- increment API_VERSION to 10

- --help and -h arguments in upnpc.c

- define MAXHOSTNAMELEN if not already done

- update upnpreplyparse to allow larger values (128 chars instead of 64)

- Update upnpreplyparse to take into account 'empty' elements

- validate upnpreplyparse.c code with 'make check'

- Fix Solaris build thanks to Maciej Małecki

- Fix for BSD

- Fixed Makefile for *BSD

- Update Makefile to use JNAerator version 0.11

- Fix for use with dash

- Use $(DESTDIR) in Makefile


Update the affected miniupnpc packages.

See Also

Plugin Details

Severity: Medium

ID: 76137

File Name: openSUSE-2014-431.nasl

Version: $Revision: 1.2 $

Type: local

Agent: unix

Published: 2014/06/19

Modified: 2014/09/14

Dependencies: 12634

Risk Information

Risk Factor: Medium


Base Score: 5

Vector: CVSS2#AV:N/AC:L/Au:N/C:N/I:N/A:P

Vulnerability Information

CPE: p-cpe:/a:novell:opensuse:libminiupnpc-devel, p-cpe:/a:novell:opensuse:libminiupnpc10, p-cpe:/a:novell:opensuse:libminiupnpc10-debuginfo, p-cpe:/a:novell:opensuse:miniupnpc, p-cpe:/a:novell:opensuse:miniupnpc-debuginfo, p-cpe:/a:novell:opensuse:python-miniupnpc, p-cpe:/a:novell:opensuse:python-miniupnpc-debuginfo, cpe:/o:novell:opensuse:12.3, cpe:/o:novell:opensuse:13.1

Required KB Items: Host/local_checks_enabled, Host/SuSE/release, Host/SuSE/rpm-list, Host/cpu

Patch Publication Date: 2014/06/11

Reference Information

CVE: CVE-2014-3985