IBM DB2 9.1 TLS/SSL Multiple DoS Vulnerabilities

High Nessus Plugin ID 76112

Synopsis

The remote database server is affected by multiple denial of service vulnerabilities.

Description

According to its version, the installation of IBM DB2 running on the remote host is version 9.1. It is, therefore, affected by one or more of the following vulnerabilities :

- An unspecified error exists related to handling malformed certificate chains that could allow denial of service attacks. (CVE-2013-6747)

- An unspecified error exists related to the TLS implementation that could allow certain error cases to cause 100% CPU utilization. (CVE-2014-0963)

Solution

If the install is under an extended support contract, please contact the vendor for a patch.

Alternatively, upgrade to one of the latest supported versions.

See Also

http://www-01.ibm.com/support/docview.wss?uid=swg21671732

Plugin Details

Severity: High

ID: 76112

File Name: db2_91_tls_ssl_dos.nasl

Version: 1.6

Type: remote

Family: Databases

Published: 2014/06/18

Updated: 2018/07/06

Dependencies: 22016

Configuration: Enable paranoid mode

Risk Information

Risk Factor: High

CVSS v2.0

Base Score: 7.1

Temporal Score: 5.3

Vector: CVSS2#AV:N/AC:M/Au:N/C:N/I:N/A:C

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

CVSS v3.0

Base Score: 7.5

Temporal Score: 6.5

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Temporal Vector: CVSS:3.0/E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:ibm:db2

Required KB Items: Settings/ParanoidReport

Exploit Available: false

Exploit Ease: No known exploits are available

Vulnerability Publication Date: 2014/01/24

Reference Information

CVE: CVE-2013-6747, CVE-2014-0963

BID: 65156, 67238