openSUSE Security Update : ruby (openSUSE-SU-2011:0556-1)

Medium Nessus Plugin ID 76014

Synopsis

The remote openSUSE host is missing a security update.

Description

A memory corruption in the BigDecimal class potentially allowed attackers to execute arbitrary code (CVE-2011-0188).

Affects 64bit platforms only.

Solution

Update the affected ruby packages.

See Also

https://bugzilla.novell.com/show_bug.cgi?id=682287

https://lists.opensuse.org/opensuse-updates/2011-05/msg00059.html

Plugin Details

Severity: Medium

ID: 76014

File Name: suse_11_4_ruby-110517.nasl

Version: 1.4

Type: local

Agent: unix

Published: 2014/06/13

Updated: 2019/10/25

Dependencies: 12634

Risk Information

Risk Factor: Medium

CVSS v2.0

Base Score: 6.8

Vector: CVSS2#AV:N/AC:M/Au:N/C:P/I:P/A:P

Vulnerability Information

CPE: p-cpe:/a:novell:opensuse:ruby, p-cpe:/a:novell:opensuse:ruby-debuginfo, p-cpe:/a:novell:opensuse:ruby-debugsource, p-cpe:/a:novell:opensuse:ruby-devel, p-cpe:/a:novell:opensuse:ruby-doc-html, p-cpe:/a:novell:opensuse:ruby-doc-ri, p-cpe:/a:novell:opensuse:ruby-examples, p-cpe:/a:novell:opensuse:ruby-test-suite, p-cpe:/a:novell:opensuse:ruby-tk, p-cpe:/a:novell:opensuse:ruby-tk-debuginfo, cpe:/o:novell:opensuse:11.4

Required KB Items: Host/local_checks_enabled, Host/SuSE/release, Host/SuSE/rpm-list, Host/cpu

Patch Publication Date: 2011/05/17

Reference Information

CVE: CVE-2011-0188