openSUSE Security Update : quagga (openSUSE-SU-2011:1155-1)

High Nessus Plugin ID 76007


The remote openSUSE host is missing a security update.


This update fixes the following security issues :

- 718056: OSPF6D buffer overflow while decoding Link State Update with Inter Area Prefix Lsa (CVE-2011-3323)

- 718058: OSPF6D DoS while decoding Database Description packet (CVE-2011-3324)

- 718059: OSPFD DoS while decoding Hello packet (CVE-2011-3325)

- 718061: OSPFD DoS while decoding Link State Update (CVE-2011-3326)

- 718062: DoS while decoding EXTENDED_COMMUNITIES in Quagga's BGP (CVE-2011-3327)


Update the affected quagga packages.

See Also

Plugin Details

Severity: High

ID: 76007

File Name: suse_11_4_quagga-111013.nasl

Version: $Revision: 1.1 $

Type: local

Agent: unix

Published: 2014/06/13

Modified: 2014/06/13

Dependencies: 12634

Risk Information

Risk Factor: High


Base Score: 7.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Vulnerability Information

CPE: p-cpe:/a:novell:opensuse:quagga, p-cpe:/a:novell:opensuse:quagga-debuginfo, p-cpe:/a:novell:opensuse:quagga-debugsource, p-cpe:/a:novell:opensuse:quagga-devel, cpe:/o:novell:opensuse:11.4

Required KB Items: Host/local_checks_enabled, Host/SuSE/release, Host/SuSE/rpm-list, Host/cpu

Patch Publication Date: 2011/10/13

Reference Information

CVE: CVE-2011-3323, CVE-2011-3324, CVE-2011-3325, CVE-2011-3326, CVE-2011-3327