openSUSE Security Update : python-cupshelpers (openSUSE-SU-2011:1331-2)

High Nessus Plugin ID 76002


The remote openSUSE host is missing a security update.


This update fixes a typo from the previous update :

system-config-printer used an unauthenticated connection when downloading printer drivers from (CVE-2011-4405).
This update disables the printer driver download feature.

system-config-printer did not properly quote shell meta characters in SMB server or workgroup names when passing them to the shell (CVE-2011-2899).


Update the affected python-cupshelpers packages.

See Also

Plugin Details

Severity: High

ID: 76002

File Name: suse_11_4_python-cupshelpers-120103.nasl

Version: $Revision: 1.1 $

Type: local

Agent: unix

Published: 2014/06/13

Modified: 2014/06/13

Dependencies: 12634

Risk Information

Risk Factor: High


Base Score: 7.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Vulnerability Information

CPE: p-cpe:/a:novell:opensuse:python-cupshelpers, p-cpe:/a:novell:opensuse:system-config-printer, p-cpe:/a:novell:opensuse:system-config-printer-debugsource, p-cpe:/a:novell:opensuse:system-config-printer-lang, p-cpe:/a:novell:opensuse:udev-configure-printer, p-cpe:/a:novell:opensuse:udev-configure-printer-debuginfo, cpe:/o:novell:opensuse:11.4

Required KB Items: Host/local_checks_enabled, Host/SuSE/release, Host/SuSE/rpm-list, Host/cpu

Patch Publication Date: 2012/01/03

Reference Information

CVE: CVE-2011-2899, CVE-2011-4405