openSUSE Security Update : nginx-0.8 (openSUSE-SU-2012:0237-1)

Medium Nessus Plugin ID 75979


The remote openSUSE host is missing a security update.


A flaw in the custom DNS resolver of nginx could lead to a heap based buffer overflow which could potentially allow attackers to execute arbitrary code or to cause a Denial of Service (bnc#731084, CVE-2011-4315).


Update the affected nginx-0.8 packages.

See Also

Plugin Details

Severity: Medium

ID: 75979

File Name: suse_11_4_nginx-0_8-111121.nasl

Version: $Revision: 1.1 $

Type: local

Agent: unix

Published: 2014/06/13

Modified: 2014/06/13

Dependencies: 12634

Risk Information

Risk Factor: Medium


Base Score: 5

Vector: CVSS2#AV:N/AC:L/Au:N/C:N/I:N/A:P

Vulnerability Information

CPE: p-cpe:/a:novell:opensuse:nginx-0.8, p-cpe:/a:novell:opensuse:nginx-0.8-debuginfo, p-cpe:/a:novell:opensuse:nginx-0.8-debugsource, cpe:/o:novell:opensuse:11.4

Required KB Items: Host/local_checks_enabled, Host/SuSE/release, Host/SuSE/rpm-list, Host/cpu

Patch Publication Date: 2011/11/21

Reference Information

CVE: CVE-2011-4315