openSUSE Security Update : libsoup-2_4-1 (openSUSE-SU-2011:0875-1)

Medium Nessus Plugin ID 75921


The remote openSUSE host is missing a security update.


This update of libsoup fixes a directory traversal attack that affect application using the library. CVE-2011-2524: CVSS v2 Base Score: 5.0 (AV:N/AC:L/Au:N/C:P/I:N/A:N)


Update the affected libsoup-2_4-1 packages.

See Also

Plugin Details

Severity: Medium

ID: 75921

File Name: suse_11_4_libsoup-2_4-1-110729.nasl

Version: $Revision: 1.1 $

Type: local

Agent: unix

Published: 2014/06/13

Modified: 2014/06/13

Dependencies: 12634

Risk Information

Risk Factor: Medium


Base Score: 5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:N/A:N

Vulnerability Information

CPE: p-cpe:/a:novell:opensuse:libsoup-2_4-1, p-cpe:/a:novell:opensuse:libsoup-2_4-1-32bit, p-cpe:/a:novell:opensuse:libsoup-2_4-1-debuginfo, p-cpe:/a:novell:opensuse:libsoup-2_4-1-debuginfo-32bit, cpe:/o:novell:opensuse:11.4

Required KB Items: Host/local_checks_enabled, Host/SuSE/release, Host/SuSE/rpm-list, Host/cpu

Patch Publication Date: 2011/07/29

Reference Information

CVE: CVE-2011-2524