openSUSE Security Update : libsndfile (openSUSE-SU-2011:0855-1)

Medium Nessus Plugin ID 75920


The remote openSUSE host is missing a security update.


An integer overflow in libsndfile while processing certain PAF files has been fixed. CVE-2011-2696 has been assigned to this issue.


Update the affected libsndfile packages.

See Also

Plugin Details

Severity: Medium

ID: 75920

File Name: suse_11_4_libsndfile-110719.nasl

Version: $Revision: 1.1 $

Type: local

Agent: unix

Published: 2014/06/13

Modified: 2014/06/13

Dependencies: 12634

Risk Information

Risk Factor: Medium


Base Score: 6.8

Vector: CVSS2#AV:N/AC:M/Au:N/C:P/I:P/A:P

Vulnerability Information

CPE: p-cpe:/a:novell:opensuse:libsndfile, p-cpe:/a:novell:opensuse:libsndfile-32bit, p-cpe:/a:novell:opensuse:libsndfile-debuginfo, p-cpe:/a:novell:opensuse:libsndfile-debuginfo-32bit, p-cpe:/a:novell:opensuse:libsndfile-debugsource, p-cpe:/a:novell:opensuse:libsndfile-devel, cpe:/o:novell:opensuse:11.4

Required KB Items: Host/local_checks_enabled, Host/SuSE/release, Host/SuSE/rpm-list, Host/cpu

Patch Publication Date: 2011/07/19

Reference Information

CVE: CVE-2011-2696