openSUSE Security Update : libmariadbclient16 (openSUSE-SU-2011:0743-1)

Medium Nessus Plugin ID 75898

Synopsis

The remote openSUSE host is missing a security update.

Description

MariaDB was updated to version 5.1.55 to fix numerous bugs and security issues.

Solution

Update the affected libmariadbclient16 packages.

See Also

https://bugzilla.novell.com/show_bug.cgi?id=676973

https://lists.opensuse.org/opensuse-updates/2011-07/msg00005.html

Plugin Details

Severity: Medium

ID: 75898

File Name: suse_11_4_libmariadbclient16-110701.nasl

Version: 1.2

Type: local

Agent: unix

Published: 2014/06/13

Updated: 2018/11/10

Dependencies: 12634

Risk Information

Risk Factor: Medium

CVSS v2.0

Base Score: 5

Vector: CVSS2#AV:N/AC:L/Au:N/C:N/I:N/A:P

Vulnerability Information

CPE: p-cpe:/a:novell:opensuse:libmariadbclient16, p-cpe:/a:novell:opensuse:libmariadbclient16-debuginfo, p-cpe:/a:novell:opensuse:libmariadbclient_r16, p-cpe:/a:novell:opensuse:libmariadbclient_r16-debuginfo, p-cpe:/a:novell:opensuse:mariadb, p-cpe:/a:novell:opensuse:mariadb-bench, p-cpe:/a:novell:opensuse:mariadb-bench-debuginfo, p-cpe:/a:novell:opensuse:mariadb-client, p-cpe:/a:novell:opensuse:mariadb-client-debuginfo, p-cpe:/a:novell:opensuse:mariadb-debug, p-cpe:/a:novell:opensuse:mariadb-debug-debuginfo, p-cpe:/a:novell:opensuse:mariadb-debuginfo, p-cpe:/a:novell:opensuse:mariadb-debugsource, p-cpe:/a:novell:opensuse:mariadb-test, p-cpe:/a:novell:opensuse:mariadb-test-debuginfo, p-cpe:/a:novell:opensuse:mariadb-tools, p-cpe:/a:novell:opensuse:mariadb-tools-debuginfo, cpe:/o:novell:opensuse:11.4

Required KB Items: Host/local_checks_enabled, Host/SuSE/release, Host/SuSE/rpm-list, Host/cpu

Patch Publication Date: 2011/07/01

Reference Information

CVE: CVE-2010-3833, CVE-2010-3834, CVE-2010-3835, CVE-2010-3836, CVE-2010-3837, CVE-2010-3838, CVE-2010-3839, CVE-2010-3840