openSUSE Security Update : libgnomesu (openSUSE-SU-2011:0694-1)

High Nessus Plugin ID 75897


The remote openSUSE host is missing a security update.


The libgnomesu pam backend did not check the return value of the setuid() functions. Local users could exploit that to gain root privileges (CVE-2011-1946).


Update the affected libgnomesu packages.

See Also

Plugin Details

Severity: High

ID: 75897

File Name: suse_11_4_libgnomesu-110620.nasl

Version: $Revision: 1.1 $

Type: local

Agent: unix

Published: 2014/06/13

Modified: 2014/06/13

Dependencies: 12634

Risk Information

Risk Factor: High


Base Score: 7.2

Vector: CVSS2#AV:L/AC:L/Au:N/C:C/I:C/A:C

Vulnerability Information

CPE: p-cpe:/a:novell:opensuse:libgnomesu, p-cpe:/a:novell:opensuse:libgnomesu-debuginfo, p-cpe:/a:novell:opensuse:libgnomesu-debugsource, p-cpe:/a:novell:opensuse:libgnomesu-devel, p-cpe:/a:novell:opensuse:libgnomesu-lang, p-cpe:/a:novell:opensuse:libgnomesu0, p-cpe:/a:novell:opensuse:libgnomesu0-debuginfo, cpe:/o:novell:opensuse:11.4

Required KB Items: Host/local_checks_enabled, Host/SuSE/release, Host/SuSE/rpm-list, Host/cpu

Patch Publication Date: 2011/06/20

Reference Information

CVE: CVE-2011-1946