openSUSE Security Update : iproxy (openSUSE-SU-2012:0345-1)

Medium Nessus Plugin ID 75867


The remote openSUSE host is missing a security update.


This update of usbmuxd fixes a heap-based buffer overflow which could be triggered via an overly long 'SerialNumber' field (CVE-2012-0065).


Update the affected iproxy packages.

See Also

Plugin Details

Severity: Medium

ID: 75867

File Name: suse_11_4_iproxy-120223.nasl

Version: $Revision: 1.1 $

Type: local

Agent: unix

Published: 2014/06/13

Modified: 2014/06/13

Dependencies: 12634

Risk Information

Risk Factor: Medium


Base Score: 4.6

Vector: CVSS2#AV:L/AC:L/Au:N/C:P/I:P/A:P

Vulnerability Information

CPE: p-cpe:/a:novell:opensuse:iproxy, p-cpe:/a:novell:opensuse:iproxy-debuginfo, p-cpe:/a:novell:opensuse:libusbmuxd-devel, p-cpe:/a:novell:opensuse:libusbmuxd1, p-cpe:/a:novell:opensuse:libusbmuxd1-debuginfo, p-cpe:/a:novell:opensuse:usbmuxd, p-cpe:/a:novell:opensuse:usbmuxd-debuginfo, p-cpe:/a:novell:opensuse:usbmuxd-debugsource, cpe:/o:novell:opensuse:11.4

Required KB Items: Host/local_checks_enabled, Host/SuSE/release, Host/SuSE/rpm-list, Host/cpu

Patch Publication Date: 2012/02/23

Reference Information

CVE: CVE-2012-0065

OSVDB: 78358