openSUSE Security Update : gimp (openSUSE-SU-2011:1152-1)

medium Nessus Plugin ID 75850

Synopsis

The remote openSUSE host is missing a security update.

Description

specially crafted gif files could cause an infinite loop or a heap-based buffer overflow in the gif decoder (CVE-2011-2896).

Solution

Update the affected gimp packages.

See Also

https://bugzilla.novell.com/show_bug.cgi?id=711491

https://lists.opensuse.org/opensuse-updates/2011-10/msg00020.html

Plugin Details

Severity: Medium

ID: 75850

File Name: suse_11_4_gimp-110916.nasl

Version: 1.5

Type: local

Agent: unix

Published: 6/13/2014

Updated: 1/14/2021

Supported Sensors: Nessus Agent

Risk Information

VPR

Risk Factor: Medium

Score: 5.9

CVSS v2

Risk Factor: Medium

Base Score: 5.1

Vector: AV:N/AC:H/Au:N/C:P/I:P/A:P

Vulnerability Information

CPE: p-cpe:/a:novell:opensuse:gimp, p-cpe:/a:novell:opensuse:gimp-branding-upstream, p-cpe:/a:novell:opensuse:gimp-debuginfo, p-cpe:/a:novell:opensuse:gimp-debugsource, p-cpe:/a:novell:opensuse:gimp-devel, p-cpe:/a:novell:opensuse:gimp-devel-debuginfo, p-cpe:/a:novell:opensuse:gimp-help-browser, p-cpe:/a:novell:opensuse:gimp-help-browser-debuginfo, p-cpe:/a:novell:opensuse:gimp-lang, p-cpe:/a:novell:opensuse:gimp-module-hal, p-cpe:/a:novell:opensuse:gimp-module-hal-debuginfo, p-cpe:/a:novell:opensuse:gimp-plugins-python, p-cpe:/a:novell:opensuse:gimp-plugins-python-debuginfo, p-cpe:/a:novell:opensuse:libgimp-2_0-0, p-cpe:/a:novell:opensuse:libgimp-2_0-0-32bit, p-cpe:/a:novell:opensuse:libgimp-2_0-0-debuginfo, p-cpe:/a:novell:opensuse:libgimp-2_0-0-debuginfo-32bit, p-cpe:/a:novell:opensuse:libgimpui-2_0-0, p-cpe:/a:novell:opensuse:libgimpui-2_0-0-32bit, p-cpe:/a:novell:opensuse:libgimpui-2_0-0-debuginfo, p-cpe:/a:novell:opensuse:libgimpui-2_0-0-debuginfo-32bit, cpe:/o:novell:opensuse:11.4

Required KB Items: Host/local_checks_enabled, Host/SuSE/release, Host/SuSE/rpm-list, Host/cpu

Patch Publication Date: 9/16/2011

Reference Information

CVE: CVE-2011-2896