openSUSE Security Update : ark (openSUSE-SU-2012:0322-1)

Medium Nessus Plugin ID 75792

Synopsis

The remote openSUSE host is missing a security update.

Description

Ark was prone to a path traversal vulnerability allowing a maliciously-crafted zip file to allow for an arbitrary file to be displayed and, if the user has appropriate credentials, removed (CVE-2011-2725).

Solution

Update the affected ark packages.

See Also

https://bugzilla.novell.com/show_bug.cgi?id=708268

https://lists.opensuse.org/opensuse-updates/2012-03/msg00002.html

Plugin Details

Severity: Medium

ID: 75792

File Name: suse_11_4_ark-120228.nasl

Version: 1.4

Type: local

Agent: unix

Published: 2014/06/13

Updated: 2020/06/04

Dependencies: 12634

Risk Information

Risk Factor: Medium

CVSS v2.0

Base Score: 6.8

Vector: CVSS2#AV:N/AC:M/Au:N/C:P/I:P/A:P

Vulnerability Information

CPE: p-cpe:/a:novell:opensuse:ark, p-cpe:/a:novell:opensuse:ark-debuginfo, p-cpe:/a:novell:opensuse:filelight, p-cpe:/a:novell:opensuse:filelight-debuginfo, p-cpe:/a:novell:opensuse:kcalc, p-cpe:/a:novell:opensuse:kcalc-debuginfo, p-cpe:/a:novell:opensuse:kcharselect, p-cpe:/a:novell:opensuse:kcharselect-debuginfo, p-cpe:/a:novell:opensuse:kde4-printer-applet, p-cpe:/a:novell:opensuse:kdeutils4, p-cpe:/a:novell:opensuse:kdeutils4-debugsource, p-cpe:/a:novell:opensuse:kdf, p-cpe:/a:novell:opensuse:kdf-debuginfo, p-cpe:/a:novell:opensuse:kfloppy, p-cpe:/a:novell:opensuse:kfloppy-debuginfo, p-cpe:/a:novell:opensuse:kgpg, p-cpe:/a:novell:opensuse:kgpg-debuginfo, p-cpe:/a:novell:opensuse:kremotecontrol, p-cpe:/a:novell:opensuse:kremotecontrol-debuginfo, p-cpe:/a:novell:opensuse:ktimer, p-cpe:/a:novell:opensuse:ktimer-debuginfo, p-cpe:/a:novell:opensuse:kwalletmanager, p-cpe:/a:novell:opensuse:kwalletmanager-debuginfo, p-cpe:/a:novell:opensuse:kwikdisk, p-cpe:/a:novell:opensuse:kwikdisk-debuginfo, p-cpe:/a:novell:opensuse:superkaramba, p-cpe:/a:novell:opensuse:superkaramba-debuginfo, p-cpe:/a:novell:opensuse:sweeper, p-cpe:/a:novell:opensuse:sweeper-debuginfo, cpe:/o:novell:opensuse:11.4

Required KB Items: Host/local_checks_enabled, Host/SuSE/release, Host/SuSE/rpm-list, Host/cpu

Patch Publication Date: 2012/02/28

Reference Information

CVE: CVE-2011-2725