openSUSE Security Update : strongswan (openSUSE-SU-2010:0496-1)

High Nessus Plugin ID 75749


The remote openSUSE host is missing a security update.


Remote unauthenticated attackers could cause a buffer overflow in strongswan's IKE deamon by using specially crafted certificates or identify information. Attackers could potentially exploit that to execute code (CVE-2010-2628).


Update the affected strongswan packages.

See Also

Plugin Details

Severity: High

ID: 75749

File Name: suse_11_3_strongswan-100802.nasl

Version: $Revision: 1.1 $

Type: local

Agent: unix

Published: 2014/06/13

Modified: 2014/06/13

Dependencies: 12634

Risk Information

Risk Factor: High


Base Score: 7.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Vulnerability Information

CPE: p-cpe:/a:novell:opensuse:strongswan, p-cpe:/a:novell:opensuse:strongswan-ikev1, p-cpe:/a:novell:opensuse:strongswan-ikev2, p-cpe:/a:novell:opensuse:strongswan-ipsec, p-cpe:/a:novell:opensuse:strongswan-libs0, p-cpe:/a:novell:opensuse:strongswan-nm, cpe:/o:novell:opensuse:11.3

Required KB Items: Host/local_checks_enabled, Host/SuSE/release, Host/SuSE/rpm-list, Host/cpu

Patch Publication Date: 2010/08/02

Reference Information

CVE: CVE-2010-2628