openSUSE Security Update : ncpfs (openSUSE-SU-2011:0985-1)

medium Nessus Plugin ID 75680
New! Vulnerability Priority Rating (VPR)

Tenable calculates a dynamic VPR for every vulnerability. VPR combines vulnerability information with threat intelligence and machine learning algorithms to predict which vulnerabilities are most likely to be exploited in attacks. Read more about what VPR is and how it is different from CVSS.

VPR Score: 5.9

Synopsis

The remote openSUSE host is missing a security update.

Description

Following issues are fixed by this update: The ncpfs mount and umount programs were affected by the /etc/mtab truncation problems on RLIMIT_FSIZE. (CVE-2011-1679)

Also on errors, the mtab lock was not removed, blocking other applications from modifying /etc/mtab. (CVE-2011-1680)

Solution

Update the affected ncpfs packages.

See Also

https://bugzilla.novell.com/show_bug.cgi?id=686554

https://lists.opensuse.org/opensuse-updates/2011-09/msg00000.html

Plugin Details

Severity: Medium

ID: 75680

File Name: suse_11_3_ncpfs-110824.nasl

Version: 1.5

Type: local

Agent: unix

Published: 6/13/2014

Updated: 1/14/2021

Dependencies: ssh_get_info.nasl

Risk Information

Risk Factor: Medium

VPR Score: 5.9

CVSS v2.0

Base Score: 4.4

Vector: AV:L/AC:M/Au:N/C:P/I:P/A:P

Vulnerability Information

CPE: p-cpe:/a:novell:opensuse:ncpfs, p-cpe:/a:novell:opensuse:ncpfs-32bit, p-cpe:/a:novell:opensuse:ncpfs-devel, cpe:/o:novell:opensuse:11.3

Required KB Items: Host/local_checks_enabled, Host/SuSE/release, Host/SuSE/rpm-list, Host/cpu

Patch Publication Date: 8/24/2011

Reference Information

CVE: CVE-2011-1089, CVE-2011-1679, CVE-2011-1680