openSUSE Security Update : libxml2 (openSUSE-SU-2012:0073-1)

High Nessus Plugin ID 75635


The remote openSUSE host is missing a security update.


Specially crafted XPath expressions could allow attackers to cause a denial of service or possibly have unspecified other impact (CVE-2011-2821,CVE-2011-2834).


Update the affected libxml2 packages.

See Also

Plugin Details

Severity: High

ID: 75635

File Name: suse_11_3_libxml2-111201.nasl

Version: $Revision: 1.1 $

Type: local

Agent: unix

Published: 2014/06/13

Modified: 2014/06/13

Dependencies: 12634

Risk Information

Risk Factor: High


Base Score: 7.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Vulnerability Information

CPE: p-cpe:/a:novell:opensuse:libxml2, p-cpe:/a:novell:opensuse:libxml2-32bit, p-cpe:/a:novell:opensuse:libxml2-devel, p-cpe:/a:novell:opensuse:libxml2-devel-32bit, cpe:/o:novell:opensuse:11.3

Required KB Items: Host/local_checks_enabled, Host/SuSE/release, Host/SuSE/rpm-list, Host/cpu

Patch Publication Date: 2011/12/01

Reference Information

CVE: CVE-2011-2821, CVE-2011-2834

OSVDB: 74695, 75560