openSUSE Security Update : libxcrypt (openSUSE-SU-2011:0972-1)

Medium Nessus Plugin ID 75631

Synopsis

The remote openSUSE host is missing a security update.

Description

The security update for CVE-2011-2483 broke changing blowfish passwords if compat mode was turned on (default). This update fixes the regression.

Solution

Update the affected libxcrypt packages.

See Also

https://bugzilla.novell.com/show_bug.cgi?id=713727

https://lists.opensuse.org/opensuse-updates/2011-08/msg00045.html

Plugin Details

Severity: Medium

ID: 75631

File Name: suse_11_3_libxcrypt-110824.nasl

Version: 1.4

Type: local

Agent: unix

Published: 2014/06/13

Updated: 2019/10/25

Dependencies: 12634

Risk Information

Risk Factor: Medium

CVSS v2.0

Base Score: 5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:N/A:N

Vulnerability Information

CPE: p-cpe:/a:novell:opensuse:libxcrypt, p-cpe:/a:novell:opensuse:libxcrypt-32bit, p-cpe:/a:novell:opensuse:libxcrypt-devel, cpe:/o:novell:opensuse:11.3

Required KB Items: Host/local_checks_enabled, Host/SuSE/release, Host/SuSE/rpm-list, Host/cpu

Patch Publication Date: 2011/08/24

Reference Information

CVE: CVE-2011-2483