openSUSE Security Update : libwebkit (openSUSE-SU-2010:0666-1)

High Nessus Plugin ID 75628

Synopsis

The remote openSUSE host is missing a security update.

Description

The browser engine libwebkit was updated to version 1.2.4 to fix several security bugs. (CVE-2010-1781, CVE-2010-1782, CVE-2010-1784, CVE-2010-1785 CVE-2010-1786, CVE-2010-1787, CVE-2010-1788, CVE-2010-1790 CVE-2010-1792, CVE-2010-1793, CVE-2010-2648)

Solution

Update the affected libwebkit packages.

See Also

https://bugzilla.novell.com/show_bug.cgi?id=640409

https://lists.opensuse.org/opensuse-updates/2010-09/msg00047.html

Plugin Details

Severity: High

ID: 75628

File Name: suse_11_3_libwebkit-100920.nasl

Version: 1.2

Type: local

Agent: unix

Published: 2014/06/13

Updated: 2018/11/10

Dependencies: 12634

Risk Information

Risk Factor: High

CVSS v2.0

Base Score: 9.3

Vector: CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C

Vulnerability Information

CPE: p-cpe:/a:novell:opensuse:libwebkit-1_0-2, p-cpe:/a:novell:opensuse:libwebkit-1_0-2-32bit, p-cpe:/a:novell:opensuse:libwebkit-devel, p-cpe:/a:novell:opensuse:libwebkit-lang, p-cpe:/a:novell:opensuse:webkit-jsc, cpe:/o:novell:opensuse:11.3

Required KB Items: Host/local_checks_enabled, Host/SuSE/release, Host/SuSE/rpm-list, Host/cpu

Patch Publication Date: 2010/09/20

Reference Information

CVE: CVE-2010-1781, CVE-2010-1782, CVE-2010-1784, CVE-2010-1785, CVE-2010-1786, CVE-2010-1787, CVE-2010-1788, CVE-2010-1790, CVE-2010-1792, CVE-2010-1793, CVE-2010-2648