openSUSE Security Update : libsvn_auth_gnome_keyring-1-0 (openSUSE-SU-2011:0693-1)

Medium Nessus Plugin ID 75617

Synopsis

The remote openSUSE host is missing a security update.

Description

- CVE-2011-1752: The mod_dav_svn Apache HTTPD server module can be crashed though when asked to deliver baselined WebDAV resources.

- CVE-2011-1783: The mod_dav_svn Apache HTTPD server module can trigger a loop which consumes all available memory on the system.

- CVE-2011-1921: The mod_dav_svn Apache HTTPD server module may leak to remote users the file contents of files configured to be unreadable by those users.

- CVE-2011-0715: Remote attackers could crash an svn server by causing a NULL deref

Solution

Update the affected libsvn_auth_gnome_keyring-1-0 packages.

See Also

https://bugzilla.novell.com/show_bug.cgi?id=676949

https://bugzilla.novell.com/show_bug.cgi?id=688968

https://bugzilla.novell.com/show_bug.cgi?id=698205

https://lists.opensuse.org/opensuse-updates/2011-06/msg00040.html

Plugin Details

Severity: Medium

ID: 75617

File Name: suse_11_3_libsvn_auth_gnome_keyring-1-0-110607.nasl

Version: 1.2

Type: local

Agent: unix

Published: 2014/06/13

Updated: 2018/11/10

Dependencies: 12634

Risk Information

Risk Factor: Medium

CVSS v2.0

Base Score: 5

Vector: CVSS2#AV:N/AC:L/Au:N/C:N/I:N/A:P

Vulnerability Information

CPE: p-cpe:/a:novell:opensuse:libsvn_auth_gnome_keyring-1-0, p-cpe:/a:novell:opensuse:libsvn_auth_kwallet-1-0, p-cpe:/a:novell:opensuse:subversion, p-cpe:/a:novell:opensuse:subversion-devel, p-cpe:/a:novell:opensuse:subversion-perl, p-cpe:/a:novell:opensuse:subversion-python, p-cpe:/a:novell:opensuse:subversion-ruby, p-cpe:/a:novell:opensuse:subversion-server, p-cpe:/a:novell:opensuse:subversion-tools, cpe:/o:novell:opensuse:11.3

Required KB Items: Host/local_checks_enabled, Host/SuSE/release, Host/SuSE/rpm-list, Host/cpu

Patch Publication Date: 2011/06/07

Reference Information

CVE: CVE-2011-0715, CVE-2011-1752, CVE-2011-1783, CVE-2011-1921