openSUSE Security Update : libsndfile (openSUSE-SU-2011:0854-1)

Medium Nessus Plugin ID 75613


The remote openSUSE host is missing a security update.


An integer overflow in libsndfile while processing certain PAF files has been fixed. CVE-2011-2696 has been assigned to this issue.
Additionally an divide by zero (CVE-2009-4835) has been fixed.


Update the affected libsndfile packages.

See Also

Plugin Details

Severity: Medium

ID: 75613

File Name: suse_11_3_libsndfile-110719.nasl

Version: $Revision: 1.1 $

Type: local

Agent: unix

Published: 2014/06/13

Modified: 2014/06/13

Dependencies: 12634

Risk Information

Risk Factor: Medium


Base Score: 6.8

Vector: CVSS2#AV:N/AC:M/Au:N/C:P/I:P/A:P

Vulnerability Information

CPE: p-cpe:/a:novell:opensuse:libsndfile, p-cpe:/a:novell:opensuse:libsndfile-32bit, p-cpe:/a:novell:opensuse:libsndfile-devel, cpe:/o:novell:opensuse:11.3

Required KB Items: Host/local_checks_enabled, Host/SuSE/release, Host/SuSE/rpm-list, Host/cpu

Patch Publication Date: 2011/07/19

Reference Information

CVE: CVE-2009-4835, CVE-2011-2696