openSUSE Security Update : libQtWebKit-devel (openSUSE-SU-2011:1119-1)

High Nessus Plugin ID 75609

Synopsis

The remote openSUSE host is missing a security update.

Description

Specially crafted font files could cause a single byte heap based buffer overflow (CVE-2011-3193).

Specially crafted grey scale images could cause a heap based buffer overflow (CVE-2011-3194).

The update also fixes the following non-security bugs :

- fix QFileDialog not showing system files (bnc#669604)

- fix font fallback handling (bnc#643848)

- add support for postgresql 8.3 and 9 (bnc#668210)

- Path added: bnc#592962 - Set application icon.

Solution

Update the affected libQtWebKit-devel packages.

See Also

https://bugzilla.novell.com/show_bug.cgi?id=592962

https://bugzilla.novell.com/show_bug.cgi?id=637275

https://bugzilla.novell.com/show_bug.cgi?id=643848

https://bugzilla.novell.com/show_bug.cgi?id=668210

https://bugzilla.novell.com/show_bug.cgi?id=669604

https://bugzilla.novell.com/show_bug.cgi?id=714984

https://lists.opensuse.org/opensuse-updates/2011-10/msg00007.html

Plugin Details

Severity: High

ID: 75609

File Name: suse_11_3_libQtWebKit-devel-110908.nasl

Version: 1.5

Type: local

Agent: unix

Published: 2014/06/13

Updated: 2019/10/25

Dependencies: 12634

Risk Information

Risk Factor: High

CVSS v2.0

Base Score: 9.3

Vector: CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C

Vulnerability Information

CPE: p-cpe:/a:novell:opensuse:libQtWebKit-devel, p-cpe:/a:novell:opensuse:libQtWebKit4, p-cpe:/a:novell:opensuse:libQtWebKit4-32bit, p-cpe:/a:novell:opensuse:libqt4, p-cpe:/a:novell:opensuse:libqt4-32bit, p-cpe:/a:novell:opensuse:libqt4-devel, p-cpe:/a:novell:opensuse:libqt4-devel-doc-data, p-cpe:/a:novell:opensuse:libqt4-qt3support, p-cpe:/a:novell:opensuse:libqt4-qt3support-32bit, p-cpe:/a:novell:opensuse:libqt4-sql, p-cpe:/a:novell:opensuse:libqt4-sql-32bit, p-cpe:/a:novell:opensuse:libqt4-sql-mysql, p-cpe:/a:novell:opensuse:libqt4-sql-mysql-32bit, p-cpe:/a:novell:opensuse:libqt4-sql-postgresql, p-cpe:/a:novell:opensuse:libqt4-sql-postgresql-32bit, p-cpe:/a:novell:opensuse:libqt4-sql-sqlite, p-cpe:/a:novell:opensuse:libqt4-sql-sqlite-32bit, p-cpe:/a:novell:opensuse:libqt4-sql-unixODBC, p-cpe:/a:novell:opensuse:libqt4-sql-unixODBC-32bit, p-cpe:/a:novell:opensuse:libqt4-x11, p-cpe:/a:novell:opensuse:libqt4-x11-32bit, p-cpe:/a:novell:opensuse:qt4-x11-tools, cpe:/o:novell:opensuse:11.3

Required KB Items: Host/local_checks_enabled, Host/SuSE/release, Host/SuSE/rpm-list, Host/cpu

Patch Publication Date: 2011/09/08

Reference Information

CVE: CVE-2011-3193, CVE-2011-3194