openSUSE Security Update : libpoppler-devel (openSUSE-SU-2010:0976-1)

Medium Nessus Plugin ID 75606


The remote openSUSE host is missing a security update.


Specially crafted PDF files could crash poppler or potentially even cause execution of arbitrary code (CVE-2010-3702, CVE-2010-3703, CVE-2010-3704)


Update the affected libpoppler-devel packages.

See Also

Plugin Details

Severity: Medium

ID: 75606

File Name: suse_11_3_libpoppler-devel-101016.nasl

Version: $Revision: 1.1 $

Type: local

Agent: unix

Published: 2014/06/13

Modified: 2014/06/13

Dependencies: 12634

Risk Information

Risk Factor: Medium


Base Score: 6.8

Vector: CVSS2#AV:N/AC:M/Au:N/C:P/I:P/A:P

Vulnerability Information

CPE: p-cpe:/a:novell:opensuse:libpoppler-devel, p-cpe:/a:novell:opensuse:libpoppler-glib-devel, p-cpe:/a:novell:opensuse:libpoppler-glib4, p-cpe:/a:novell:opensuse:libpoppler5, p-cpe:/a:novell:opensuse:poppler-tools, cpe:/o:novell:opensuse:11.3

Required KB Items: Host/local_checks_enabled, Host/SuSE/release, Host/SuSE/rpm-list, Host/cpu

Patch Publication Date: 2010/10/16

Reference Information

CVE: CVE-2010-3702, CVE-2010-3703, CVE-2010-3704