openSUSE Security Update : libopenssl-devel (openSUSE-SU-2012:0083-1)

medium Nessus Plugin ID 75598
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Synopsis

The remote openSUSE host is missing a security update.

Description

Various security vulnerabilities have been fixed in openssl :

- DTLS plaintext recovery attack (CVE-2011-4108)

- uninitialized SSL 3.0 padding (CVE-2011-4576)

- malformed RFC 3779 data can cause assertion failures (CVE-2011-4577)

- SGC restart DoS attack (CVE-2011-4619)

- invalid GOST parameters DoS attack (CVE-2012-0027)

Solution

Update the affected libopenssl-devel packages.

See Also

https://bugzilla.novell.com/show_bug.cgi?id=739719

https://lists.opensuse.org/opensuse-updates/2012-01/msg00029.html

Plugin Details

Severity: Medium

ID: 75598

File Name: suse_11_3_libopenssl-devel-120111.nasl

Version: 1.6

Type: local

Agent: unix

Published: 6/13/2014

Updated: 1/19/2021

Dependencies: ssh_get_info.nasl

Risk Information

VPR

Risk Factor: Low

Score: 3.6

CVSS v2

Risk Factor: Medium

Base Score: 5

Temporal Score: 3.7

Vector: AV:N/AC:L/Au:N/C:P/I:N/A:N

Temporal Vector: E:U/RL:OF/RC:C

Vulnerability Information

CPE: p-cpe:/a:novell:opensuse:libopenssl-devel, p-cpe:/a:novell:opensuse:libopenssl1_0_0, p-cpe:/a:novell:opensuse:libopenssl1_0_0-32bit, p-cpe:/a:novell:opensuse:openssl, cpe:/o:novell:opensuse:11.3

Required KB Items: Host/local_checks_enabled, Host/SuSE/release, Host/SuSE/rpm-list, Host/cpu

Exploit Ease: No known exploits are available

Patch Publication Date: 1/11/2012

Reference Information

CVE: CVE-2011-4108, CVE-2011-4576, CVE-2011-4577, CVE-2011-4619, CVE-2012-0027