openSUSE Security Update : libopenssl-devel (openSUSE-SU-2011:1144-1)

Medium Nessus Plugin ID 75597


The remote openSUSE host is missing a security update.


OpenSSL's internal certificate verification routines could incorrectly accept a CRL whose nextUpdate field is in the past (CVE-2011-3207).

Server code for ECDH could crash if it received a specially crafted handshake message (CVE-2011-3210).


Update the affected libopenssl-devel packages.

See Also

Plugin Details

Severity: Medium

ID: 75597

File Name: suse_11_3_libopenssl-devel-110920.nasl

Version: $Revision: 1.2 $

Type: local

Agent: unix

Published: 2014/06/13

Modified: 2015/07/10

Dependencies: 12634

Risk Information

Risk Factor: Medium


Base Score: 5

Temporal Score: 3.7

Vector: CVSS2#AV:N/AC:L/Au:N/C:N/I:P/A:N

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

Vulnerability Information

CPE: p-cpe:/a:novell:opensuse:libopenssl-devel, p-cpe:/a:novell:opensuse:libopenssl0_9_8, p-cpe:/a:novell:opensuse:libopenssl0_9_8-32bit, p-cpe:/a:novell:opensuse:libopenssl1_0_0, p-cpe:/a:novell:opensuse:libopenssl1_0_0-32bit, p-cpe:/a:novell:opensuse:openssl, cpe:/o:novell:opensuse:11.3

Required KB Items: Host/local_checks_enabled, Host/SuSE/release, Host/SuSE/rpm-list, Host/cpu

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2011/09/20

Reference Information

CVE: CVE-2011-3207, CVE-2011-3210

OSVDB: 75229, 75230