openSUSE Security Update : libopenssl-devel (openSUSE-SU-2010:0965-2)

High Nessus Plugin ID 75593


The remote openSUSE host is missing a security update.


Multithreaded OpenSSL servers using the TLS server extension are vulnerable to a buffer overrun attack (CVE-2010-3864).


Update the affected libopenssl-devel packages.

See Also

Plugin Details

Severity: High

ID: 75593

File Name: suse_11_3_libopenssl-devel-101119.nasl

Version: $Revision: 1.1 $

Type: local

Agent: unix

Published: 2014/06/13

Modified: 2014/06/13

Dependencies: 12634

Risk Information

Risk Factor: High


Base Score: 7.6

Vector: CVSS2#AV:N/AC:H/Au:N/C:C/I:C/A:C

Vulnerability Information

CPE: p-cpe:/a:novell:opensuse:libopenssl-devel, p-cpe:/a:novell:opensuse:libopenssl0_9_8, p-cpe:/a:novell:opensuse:libopenssl0_9_8-32bit, p-cpe:/a:novell:opensuse:libopenssl1_0_0, p-cpe:/a:novell:opensuse:libopenssl1_0_0-32bit, p-cpe:/a:novell:opensuse:openssl, cpe:/o:novell:opensuse:11.3

Required KB Items: Host/local_checks_enabled, Host/SuSE/release, Host/SuSE/rpm-list, Host/cpu

Patch Publication Date: 2010/11/19

Reference Information

CVE: CVE-2010-3864