openSUSE Security Update : libmodplug (openSUSE-SU-2011:0350-1)

Medium Nessus Plugin ID 75584


The remote openSUSE host is missing a security update.


Libmodplug is vulnerable to a stack based buffer overflow when handling malicious S3M media files. CVE-2011-1574 has been assigned to this issue.


Update the affected libmodplug packages.

See Also

Plugin Details

Severity: Medium

ID: 75584

File Name: suse_11_3_libmodplug-110412.nasl

Version: $Revision: 1.1 $

Type: local

Agent: unix

Published: 2014/06/13

Modified: 2014/06/13

Dependencies: 12634

Risk Information

Risk Factor: Medium


Base Score: 6.8

Vector: CVSS2#AV:N/AC:M/Au:N/C:P/I:P/A:P

Vulnerability Information

CPE: p-cpe:/a:novell:opensuse:libmodplug-devel, p-cpe:/a:novell:opensuse:libmodplug0, p-cpe:/a:novell:opensuse:libmodplug0-32bit, cpe:/o:novell:opensuse:11.3

Required KB Items: Host/local_checks_enabled, Host/SuSE/release, Host/SuSE/rpm-list, Host/cpu

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2011/04/12

Exploitable With

CANVAS (White_Phosphorus)

Core Impact

Metasploit (VideoLAN VLC ModPlug ReadS3M Stack Buffer Overflow)

Reference Information

CVE: CVE-2011-1574