openSUSE Security Update : ldapsmb (openSUSE-SU-2010:0653-1)

High Nessus Plugin ID 75568

New! Vulnerability Priority Rating (VPR)

Tenable calculates a dynamic VPR for every vulnerability. VPR combines vulnerability information with threat intelligence and machine learning algorithms to predict which vulnerabilities are most likely to be exploited in attacks. Read more about what VPR is and how it's different from CVSS.

VPR Score: 6.7

Synopsis

The remote openSUSE host is missing a security update.

Description

A buffer overflow in the sid_parse() function of samba could potentially be exploited by remote attackers to execute arbitrary code (CVE-2010-3069).

Additionally the update also contains fixes for the following non-security issues :

bnc#567013 - Failed to join ADS Domain bnc#573246 - mounted shares via mount.cifs disappear when dhclient renews lease bnc#592198 - Samba 3.0 / 3.2 doesn't work with Windows 2008 R2 (NTLMv2) bnc#599873 - SAMBA - Problem using NTLM authentication with 2008R2 bnc#613459 - winbindd crashes in rpccli_set_timeout bnc#617153 - new printers are not seen in samba with registry bnc#619787 - Samba Causes Too Many Files In Use Error On Windows 7 bnc#630812 - net ads join failing due to malformed UPN bnc#632055 - No authentication dialog to access SMB share through Nautilus bnc#632852 - root preexec does not work as expected

Solution

Update the affected ldapsmb packages.

See Also

https://bugzilla.novell.com/show_bug.cgi?id=567013

https://bugzilla.novell.com/show_bug.cgi?id=573246

https://bugzilla.novell.com/show_bug.cgi?id=592198

https://bugzilla.novell.com/show_bug.cgi?id=599873

https://bugzilla.novell.com/show_bug.cgi?id=613459

https://bugzilla.novell.com/show_bug.cgi?id=617153

https://bugzilla.novell.com/show_bug.cgi?id=619787

https://bugzilla.novell.com/show_bug.cgi?id=630812

https://bugzilla.novell.com/show_bug.cgi?id=632055

https://bugzilla.novell.com/show_bug.cgi?id=632852

https://bugzilla.novell.com/show_bug.cgi?id=637218

https://lists.opensuse.org/opensuse-updates/2010-09/msg00040.html

Plugin Details

Severity: High

ID: 75568

File Name: suse_11_3_ldapsmb-100915.nasl

Version: 1.4

Type: local

Agent: unix

Published: 2014/06/13

Updated: 2019/10/25

Dependencies: 12634

Risk Information

Risk Factor: High

VPR Score: 6.7

CVSS v2.0

Base Score: 7.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Vulnerability Information

CPE: p-cpe:/a:novell:opensuse:ldapsmb, p-cpe:/a:novell:opensuse:libldb-devel, p-cpe:/a:novell:opensuse:libldb0, p-cpe:/a:novell:opensuse:libnetapi-devel, p-cpe:/a:novell:opensuse:libnetapi0, p-cpe:/a:novell:opensuse:libsmbclient-devel, p-cpe:/a:novell:opensuse:libsmbclient0, p-cpe:/a:novell:opensuse:libsmbclient0-32bit, p-cpe:/a:novell:opensuse:libsmbsharemodes-devel, p-cpe:/a:novell:opensuse:libsmbsharemodes0, p-cpe:/a:novell:opensuse:libtalloc-devel, p-cpe:/a:novell:opensuse:libtalloc2, p-cpe:/a:novell:opensuse:libtdb-devel, p-cpe:/a:novell:opensuse:libtdb1, p-cpe:/a:novell:opensuse:libtdb1-32bit, p-cpe:/a:novell:opensuse:libtevent-devel, p-cpe:/a:novell:opensuse:libtevent0, p-cpe:/a:novell:opensuse:libwbclient-devel, p-cpe:/a:novell:opensuse:libwbclient0, p-cpe:/a:novell:opensuse:libwbclient0-32bit, p-cpe:/a:novell:opensuse:samba, p-cpe:/a:novell:opensuse:samba-32bit, p-cpe:/a:novell:opensuse:samba-client, p-cpe:/a:novell:opensuse:samba-client-32bit, p-cpe:/a:novell:opensuse:samba-devel, p-cpe:/a:novell:opensuse:samba-krb-printing, p-cpe:/a:novell:opensuse:samba-winbind, p-cpe:/a:novell:opensuse:samba-winbind-32bit, cpe:/o:novell:opensuse:11.3

Required KB Items: Host/local_checks_enabled, Host/SuSE/release, Host/SuSE/rpm-list, Host/cpu

Patch Publication Date: 2010/09/15

Reference Information

CVE: CVE-2010-3069