openSUSE Security Update : gwenview (openSUSE-SU-2010:0691-1)

Medium Nessus Plugin ID 75524

Synopsis

The remote openSUSE host is missing a security update.

Description

This update fixes a heap-based overflow in okular. The RLE decompression in the TranscribePalmImageToJPEG() function can be exploited to execute arbitrary code with user privileges by providing a crafted PDF file. (CVE-2010-2575).

Solution

Update the affected gwenview packages.

See Also

https://bugzilla.novell.com/show_bug.cgi?id=634743

https://lists.opensuse.org/opensuse-updates/2010-10/msg00000.html

Plugin Details

Severity: Medium

ID: 75524

File Name: suse_11_3_gwenview-100902.nasl

Version: 1.4

Type: local

Agent: unix

Published: 2014/06/13

Updated: 2019/10/25

Dependencies: 12634

Risk Information

Risk Factor: Medium

CVSS v2.0

Base Score: 6.8

Vector: CVSS2#AV:N/AC:M/Au:N/C:P/I:P/A:P

Vulnerability Information

CPE: p-cpe:/a:novell:opensuse:gwenview, p-cpe:/a:novell:opensuse:kcolorchooser, p-cpe:/a:novell:opensuse:kdegraphics4, p-cpe:/a:novell:opensuse:kgamma, p-cpe:/a:novell:opensuse:kio_kamera, p-cpe:/a:novell:opensuse:kolourpaint, p-cpe:/a:novell:opensuse:kruler, p-cpe:/a:novell:opensuse:ksnapshot, p-cpe:/a:novell:opensuse:libkdcraw-devel, p-cpe:/a:novell:opensuse:libkdcraw8, p-cpe:/a:novell:opensuse:libkexiv2-8, p-cpe:/a:novell:opensuse:libkexiv2-devel, p-cpe:/a:novell:opensuse:libkipi-devel, p-cpe:/a:novell:opensuse:libkipi7, p-cpe:/a:novell:opensuse:libksane-devel, p-cpe:/a:novell:opensuse:libksane0, p-cpe:/a:novell:opensuse:okular, p-cpe:/a:novell:opensuse:okular-devel, cpe:/o:novell:opensuse:11.3

Required KB Items: Host/local_checks_enabled, Host/SuSE/release, Host/SuSE/rpm-list, Host/cpu

Patch Publication Date: 2010/09/02

Reference Information

CVE: CVE-2010-2575