openSUSE Security Update : glibc (openSUSE-SU-2012:0064-1)

medium Nessus Plugin ID 75520

Synopsis

The remote openSUSE host is missing a security update.

Description

Specially crafted time zone files could cause a heap overflow in glibc (CVE-2009-5029).

Solution

Update the affected glibc packages.

See Also

https://bugzilla.novell.com/show_bug.cgi?id=735850

https://lists.opensuse.org/opensuse-updates/2012-01/msg00023.html

Plugin Details

Severity: Medium

ID: 75520

File Name: suse_11_3_glibc-111219.nasl

Version: 1.6

Type: local

Agent: unix

Published: 6/13/2014

Updated: 1/14/2021

Supported Sensors: Nessus Agent

Risk Information

VPR

Risk Factor: Medium

Score: 6.7

CVSS v2

Risk Factor: Medium

Base Score: 6.8

Vector: AV:N/AC:M/Au:N/C:P/I:P/A:P

Vulnerability Information

CPE: p-cpe:/a:novell:opensuse:glibc, p-cpe:/a:novell:opensuse:glibc-32bit, p-cpe:/a:novell:opensuse:glibc-devel, p-cpe:/a:novell:opensuse:glibc-devel-32bit, p-cpe:/a:novell:opensuse:glibc-html, p-cpe:/a:novell:opensuse:glibc-i18ndata, p-cpe:/a:novell:opensuse:glibc-info, p-cpe:/a:novell:opensuse:glibc-locale, p-cpe:/a:novell:opensuse:glibc-locale-32bit, p-cpe:/a:novell:opensuse:glibc-obsolete, p-cpe:/a:novell:opensuse:glibc-profile, p-cpe:/a:novell:opensuse:glibc-profile-32bit, p-cpe:/a:novell:opensuse:nscd, cpe:/o:novell:opensuse:11.3

Required KB Items: Host/local_checks_enabled, Host/SuSE/release, Host/SuSE/rpm-list, Host/cpu

Patch Publication Date: 12/19/2011

Reference Information

CVE: CVE-2009-5029