openSUSE Security Update : gimp (openSUSE-SU-2011:0162-1)

High Nessus Plugin ID 75513


The remote openSUSE host is missing a security update.


Four buffer overflows have been fixed in gimp and its plugins.
CVE-2010-4540-CVE-2010-4543 have been assigned to these issues.

- CVE-2010-4540: CVSS v2 Base Score: 4.3 (AV:N/AC:M/Au:N/C:N/I:N/A:P): Buffer Errors (CWE-119)

- CVE-2010-4541: CVSS v2 Base Score: 4.3 (AV:N/AC:M/Au:N/C:N/I:N/A:P): Buffer Errors (CWE-119)

- CVE-2010-4542: CVSS v2 Base Score: 4.3 (AV:N/AC:M/Au:N/C:N/I:N/A:P): Buffer Errors (CWE-119)

- CVE-2010-4543: CVSS v2 Base Score: 4.3 (AV:N/AC:M/Au:N/C:N/I:N/A:P): Buffer Errors (CWE-119)


Update the affected gimp packages.

See Also

Plugin Details

Severity: High

ID: 75513

File Name: suse_11_3_gimp-110217.nasl

Version: $Revision: 1.1 $

Type: local

Agent: unix

Published: 2014/06/13

Modified: 2014/06/13

Dependencies: 12634

Risk Information

Risk Factor: High


Base Score: 9.3

Vector: CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C

Vulnerability Information

CPE: p-cpe:/a:novell:opensuse:gimp, p-cpe:/a:novell:opensuse:gimp-branding-upstream, p-cpe:/a:novell:opensuse:gimp-devel, p-cpe:/a:novell:opensuse:gimp-help-browser, p-cpe:/a:novell:opensuse:gimp-lang, p-cpe:/a:novell:opensuse:gimp-module-hal, p-cpe:/a:novell:opensuse:gimp-plugins-python, cpe:/o:novell:opensuse:11.3

Required KB Items: Host/local_checks_enabled, Host/SuSE/release, Host/SuSE/rpm-list, Host/cpu

Patch Publication Date: 2011/02/17

Reference Information

CVE: CVE-2010-4540, CVE-2010-4541, CVE-2010-4542, CVE-2010-4543