openSUSE Security Update : freetype2 (openSUSE-SU-2010:0726-1)

high Nessus Plugin ID 75504

Synopsis

The remote openSUSE host is missing a security update.

Description

When loading specially crafted font files applications linked against freetype2 could crash or potentially even execute arbitrary code (CVE-2010-3311, CVE-2010-3053, CVE-2010-3054).

Solution

Update the affected freetype2 packages.

See Also

https://bugzilla.novell.com/show_bug.cgi?id=633938

https://bugzilla.novell.com/show_bug.cgi?id=633943

https://bugzilla.novell.com/show_bug.cgi?id=641580

https://lists.opensuse.org/opensuse-updates/2010-10/msg00015.html

Plugin Details

Severity: High

ID: 75504

File Name: suse_11_3_freetype2-101013.nasl

Version: 1.5

Type: local

Agent: unix

Published: 6/13/2014

Updated: 1/14/2021

Supported Sensors: Frictionless Assessment Agent, Frictionless Assessment AWS, Frictionless Assessment Azure, Nessus Agent

Risk Information

VPR

Risk Factor: Medium

Score: 5.9

CVSS v2

Risk Factor: High

Base Score: 9.3

Vector: AV:N/AC:M/Au:N/C:C/I:C/A:C

Vulnerability Information

CPE: p-cpe:/a:novell:opensuse:freetype2-devel, p-cpe:/a:novell:opensuse:freetype2-devel-32bit, p-cpe:/a:novell:opensuse:libfreetype6, p-cpe:/a:novell:opensuse:libfreetype6-32bit, cpe:/o:novell:opensuse:11.3

Required KB Items: Host/local_checks_enabled, Host/SuSE/release, Host/SuSE/rpm-list, Host/cpu

Patch Publication Date: 10/13/2010

Reference Information

CVE: CVE-2010-3053, CVE-2010-3054, CVE-2010-3311