openSUSE Security Update : foomatic-filters (openSUSE-SU-2011:0892-1)

Medium Nessus Plugin ID 75503


The remote openSUSE host is missing a security update.


The foomatic print filters of the hplip package contained a remote code execution vulnerability. Remote users, if allowed to access a print server such as CUPS, could execute arbitrary commands as lp system user. CVE-2011-2964: CVSS v2 Base Score: 6.8 (moderate) (AV:N/AC:M/Au:N/C:P/I:P/A:P): Code Injection (CWE-94)


Update the affected foomatic-filters package.

See Also

Plugin Details

Severity: Medium

ID: 75503

File Name: suse_11_3_foomatic-filters-110810.nasl

Version: $Revision: 1.1 $

Type: local

Agent: unix

Published: 2014/06/13

Modified: 2014/06/13

Dependencies: 12634

Risk Information

Risk Factor: Medium


Base Score: 6.8

Vector: CVSS2#AV:N/AC:M/Au:N/C:P/I:P/A:P

Vulnerability Information

CPE: p-cpe:/a:novell:opensuse:foomatic-filters, cpe:/o:novell:opensuse:11.3

Required KB Items: Host/local_checks_enabled, Host/SuSE/release, Host/SuSE/rpm-list, Host/cpu

Patch Publication Date: 2011/08/10

Reference Information

CVE: CVE-2011-2697, CVE-2011-2964