openSUSE Security Update : hplip (openSUSE-SU-2014:0127-1)

Medium Nessus Plugin ID 75407


The remote openSUSE host is missing a security update.


- fix-CVE-2013-6402.dif fixes hardcoded file name /tmp/hp-pkservice.log in (bnc#852368).

- disable_hp-upgrade.patch disables hp-upgrade/ for security reasons (bnc#853405). To upgrade HPLIP an openSUSE software package manager like YaST or zypper should be used. (CVE-2013-6427)


Update the affected hplip packages.

See Also

Plugin Details

Severity: Medium

ID: 75407

File Name: openSUSE-2014-80.nasl

Version: $Revision: 1.1 $

Type: local

Agent: unix

Published: 2014/06/13

Modified: 2014/06/13

Dependencies: 12634

Risk Information

Risk Factor: Medium


Base Score: 6.8

Temporal Score: 5.9

Vector: CVSS2#AV:N/AC:M/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:ND/RL:OF/RC:C

Vulnerability Information

CPE: p-cpe:/a:novell:opensuse:hplip, p-cpe:/a:novell:opensuse:hplip-debuginfo, p-cpe:/a:novell:opensuse:hplip-debugsource, p-cpe:/a:novell:opensuse:hplip-hpijs, p-cpe:/a:novell:opensuse:hplip-hpijs-debuginfo, p-cpe:/a:novell:opensuse:hplip-sane, p-cpe:/a:novell:opensuse:hplip-sane-debuginfo, cpe:/o:novell:opensuse:12.2, cpe:/o:novell:opensuse:12.3, cpe:/o:novell:opensuse:13.1

Required KB Items: Host/local_checks_enabled, Host/SuSE/release, Host/SuSE/rpm-list, Host/cpu

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2014/01/15

Reference Information

CVE: CVE-2013-6402, CVE-2013-6427

BID: 63959, 64131