openSUSE Security Update : v8 (openSUSE-SU-2014:0092-1)

High Nessus Plugin ID 75393


The remote openSUSE host is missing a security update.


- Update spec-file to fit the changes in V8 (addition of internal ICU)

- Building against system ICU

- Regenerate Makefiles before using them

- Update to

- Security fixes (bnc#854473) :

- CVE-2013-6638: Buffer overflow in v8

- CVE-2013-6639: Out of bounds write in v8

- CVE-2013-6640: Out of bounds read in v8


Update the affected v8 packages.

See Also

Plugin Details

Severity: High

ID: 75393

File Name: openSUSE-2014-57.nasl

Version: $Revision: 1.1 $

Type: local

Agent: unix

Published: 2014/06/13

Modified: 2014/06/13

Dependencies: 12634

Risk Information

Risk Factor: High


Base Score: 7.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Vulnerability Information

CPE: p-cpe:/a:novell:opensuse:libv8-3, p-cpe:/a:novell:opensuse:libv8-3-debuginfo, p-cpe:/a:novell:opensuse:v8-devel, p-cpe:/a:novell:opensuse:v8-private-headers-devel, cpe:/o:novell:opensuse:12.2

Required KB Items: Host/local_checks_enabled, Host/SuSE/release, Host/SuSE/rpm-list, Host/cpu

Patch Publication Date: 2014/01/10

Reference Information

CVE: CVE-2013-6638, CVE-2013-6639, CVE-2013-6640