openSUSE Security Update : lightdm-gtk-greeter (openSUSE-SU-2014:0071-1)

Low Nessus Plugin ID 75386


The remote openSUSE host is missing a security update.


- add lightdm-gtk-greeter-handle-invalid-user.patch in order to fix a NULL pointer dereference after authentication of an invalid username has failed (bnc#857303, CVE-2014-0979)

- add lightdm-gtk-greeter-invalid-last_session.patch fix segfault when last_session is an invalid session (lp#1161883)

- add lightdm-gtk-greeter-fix-login.patch in order to fix login/unlock detection


Update the affected lightdm-gtk-greeter packages.

See Also

Plugin Details

Severity: Low

ID: 75386

File Name: openSUSE-2014-41.nasl

Version: $Revision: 1.1 $

Type: local

Agent: unix

Published: 2014/06/13

Modified: 2014/06/13

Dependencies: 12634

Risk Information

Risk Factor: Low


Base Score: 2.1

Temporal Score: 1.8

Vector: CVSS2#AV:L/AC:L/Au:N/C:N/I:N/A:P

Temporal Vector: CVSS2#E:ND/RL:OF/RC:C

Vulnerability Information

CPE: p-cpe:/a:novell:opensuse:lightdm-gtk-greeter, p-cpe:/a:novell:opensuse:lightdm-gtk-greeter-branding-upstream, p-cpe:/a:novell:opensuse:lightdm-gtk-greeter-debuginfo, p-cpe:/a:novell:opensuse:lightdm-gtk-greeter-debugsource, p-cpe:/a:novell:opensuse:lightdm-gtk-greeter-lang, cpe:/o:novell:opensuse:12.2, cpe:/o:novell:opensuse:12.3, cpe:/o:novell:opensuse:13.1

Required KB Items: Host/local_checks_enabled, Host/SuSE/release, Host/SuSE/rpm-list, Host/cpu

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2014/01/08

Reference Information

CVE: CVE-2014-0979

BID: 64679

OSVDB: 101846