openSUSE Security Update : libgadu (openSUSE-SU-2014:0722-1)

High Nessus Plugin ID 75378


The remote openSUSE host is missing a security update.


- Update to version 1.11.4, bugfix release :

+ Fix buffer overflow with remote code execution potential. Only triggerable by a Gadu-Gadu server or a man-in-the-middle. CVE-2013-6487 (bnc#861019, bnc#878540)

+ Fix memory overwrite in file transfer with proxy server.
CVE-2014-3775 (bnc#878540)

+ Minor fixes reported by Pidgin project members.


Update the affected libgadu packages.

See Also

Plugin Details

Severity: High

ID: 75378

File Name: openSUSE-2014-400.nasl

Version: $Revision: 1.1 $

Type: local

Agent: unix

Published: 2014/06/13

Modified: 2014/06/13

Dependencies: 12634

Risk Information

Risk Factor: High


Base Score: 7.5

Temporal Score: 6.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:ND/RL:OF/RC:C

Vulnerability Information

CPE: p-cpe:/a:novell:opensuse:libgadu-debugsource, p-cpe:/a:novell:opensuse:libgadu-devel, p-cpe:/a:novell:opensuse:libgadu3, p-cpe:/a:novell:opensuse:libgadu3-debuginfo, cpe:/o:novell:opensuse:12.3, cpe:/o:novell:opensuse:13.1

Required KB Items: Host/local_checks_enabled, Host/SuSE/release, Host/SuSE/rpm-list, Host/cpu

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2014/05/21

Reference Information

CVE: CVE-2013-6487, CVE-2014-3775

BID: 65188, 67471