openSUSE Security Update : android-tools (openSUSE-SU-2014:0636-1)

High Nessus Plugin ID 75353


The remote openSUSE host is missing a security update.


- Fix overflow in adb CVE-2014-1909 [bnc#863074]

- fix-overflow-in-adb_client.patch


Update the affected android-tools packages.

See Also

Plugin Details

Severity: High

ID: 75353

File Name: openSUSE-2014-357.nasl

Version: $Revision: 1.1 $

Type: local

Agent: unix

Published: 2014/06/13

Modified: 2014/06/13

Dependencies: 12634

Risk Information

Risk Factor: High


Base Score: 7.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Vulnerability Information

CPE: p-cpe:/a:novell:opensuse:android-tools, p-cpe:/a:novell:opensuse:android-tools-debuginfo, p-cpe:/a:novell:opensuse:android-tools-debugsource, cpe:/o:novell:opensuse:13.1

Required KB Items: Host/local_checks_enabled, Host/SuSE/release, Host/SuSE/rpm-list, Host/cpu

Patch Publication Date: 2014/05/05

Reference Information

CVE: CVE-2014-1909